Running RTTOV for 136 pressure levels

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #49590
    Parisa HeidaryParisa Heidary

    Hi everyone,

    I have a question regarding running RTTOV with the ERA5 dataset for 136 pressure levels. Initially, I downloaded the ERA5 dataset with 37 pressure levels and then interpolated it to obtain 136 levels. I used these 136 levels as input for RTTOV without making any changes to the Coefficient file (TROPICS coefficient file in the rttov13pred54L folder). The problem is that the lines are jagged when plotting the calculated Optical Depth (or even Tau) against the pressure levels.

    Does anyone have any ideas about what I might be doing wrong?


    James HockingJames Hocking

    Hi Parisa,

    This is probably due to the default interpolation mode (mode 1) used within RTTOV. If you set

    opts % interpolation % interp_mode = 4

    then the jaggedness should disappear. This is described in section 7.3 of the RTTOV v13 user guide. Generally speaking, mode 1 is recommended when the number of input levels is less than the number of coefficient levels, while modes 4 or 5 are recommended when there are more input pressure levels than coefficient levels. However, no issues have been reported when using mode 1 operationally in NWP in the latter case, for example, despite the jagged Jacobians and weighting functions.

    For more details about the interpolation modes in RTTOV see this tech memo.

    Let me know if this doesn’t help.

    As an aside, I would recommend downloading the ERA5 data on 137 levels directly rather than interpolating from the 37 fixed pressure levels. It depends on your application as to how much difference it makes, but using the native model resolution is better if you can.

    Best wishes,

    Parisa HeidaryParisa Heidary

    Hi James,

    Thank you so much for the great explanation and your help. Setting the mode number worked.
    I will also download the 137-level data to check if it provides better results. However, I am not sure if it is still available as I couldn’t find it on the website. I will search more on that.
    Thank you again. I appreciate your help.


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.